I have minecraft 1.5_01, and when I install modloader, I always get a black screen. I can open TooManyItems, so I know I can install mods. However, it's modloader that's the problem.
Can you find some mods that don't require modloader, or tell me how to correctly install them?

BTW: I install modloader by opening the minecraft.jar and inserting all the files into the .jar. When I open minecraft, i get a black screen.